import Foundation
let pattern = #"^config\s.*?(?=(?:\r?\n)+(?:config\s|\Z))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
config vdom
edit root
next
edit test
next
edit test2
next
end
config global
...
...
...
end
end
config vdom
edit root
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test2
config system
...
end
config ...
...
...
...
end
end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)