re = /^config\s.*?(?=(?:\r?\n)+(?:config\s|\Z))/m
str = 'config vdom
edit root
next
edit test
next
edit test2
next
end
config global
...
...
...
end
end
config vdom
edit root
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test
config system
...
end
config ...
...
...
......
...
end
end
config vdom
edit test2
config system
...
end
config ...
...
...
...
end
end
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end