import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([’-])\\1)[\\w',.-][^\\n\\r0-9_!¡?÷¿\\\\+=@#$%ˆ&*()\\{\\}|~<>;:[\\]]{2,}$";
final String string = "Jacob Wellman\n"
+ "Wellman, Jacob\n"
+ "Wellman, Jacob Wayne\n"
+ "O’Shaughnessy, Jake L.\n"
+ "John O’Shaughnessy-Smith\n"
+ "Kim\n\n\n"
+ "Timmy O’’Shaughnessy\n"
+ "John O’Shaughnessy--Smith\n"
+ "K3vin Malone\n"
+ "alert(“Hello”)\n"
+ "select * from users;\n"
+ "Al\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}