$re = '/^(?!.*([’-])\1)[\w\',.-][^\n\r0-9_!¡?÷¿\\\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$/mu';
$str = 'Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O’Shaughnessy, Jake L.
John O’Shaughnessy-Smith
Kim
Timmy O’’Shaughnessy
John O’Shaughnessy--Smith
K3vin Malone
alert(“Hello”)
select * from users;
Al
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);