re = /^(?!.*([’-])\1)[\w',.-][^\n\r0-9_!¡?÷¿\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$/m
str = 'Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O’Shaughnessy, Jake L.
John O’Shaughnessy-Smith
Kim
Timmy O’’Shaughnessy
John O’Shaughnessy--Smith
K3vin Malone
alert(“Hello”)
select * from users;
Al
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end