const regex = /^(?!.*([’-])\1)[\w',.-][^\n\r0-9_!¡?÷¿\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*([’-])\\1)[\\w\',.-][^\\n\\r0-9_!¡?÷¿\\\\+=@#$%ˆ&*(){}|~<>;:[\\]]{2,}$', 'gmu')
const str = `Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O’Shaughnessy, Jake L.
John O’Shaughnessy-Smith
Kim
Timmy O’’Shaughnessy
John O’Shaughnessy--Smith
K3vin Malone
alert(“Hello”)
select * from users;
Al
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}