import re
regex = re.compile(r"""
^
(?=(?:(?![mM]{2}).)*[mM]{2}(?:(?![mM]{2}).)*$)
(?=(?:(?![dD]{2}).)*[dD]{2}(?:(?![dD]{2}).)*$)
(?=(?:(?![yY]{2}(?:[yY]{2})?).)*[yY]{2}(?:[yY]{2})?(?:(?![yY]{2}(?:[yY]{2})?).)*$)
(?:
(?:[mM]{2}|[dD]{2}|[yY]{2}(?:[yY]{2})?)
(?:[_-](?!$))?
){3}
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("The expected result is that only combinations such as the following can test true:\n"
"dd-mm-yy\n"
"MM-DD_YYYY\n"
"yyyy_dd-MM\n"
"mmddyy\n"
"YYYYddMM\n\n"
"And not something like:\n"
"ddyyyyymmmmmmmmm\n"
"mmddyymm\n\n"
"ADDITIONAL no-checks:\n"
"mmmmmm\n"
"yyyymmmm\n"
"yydddd\n"
"YYYYddMM-\n"
"ddyyyy\n"
"yyyymm\n"
"yyyydd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")