using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_([^_]+_[^_]+)_[^_]+\.\w+$";
string input = @"MLID_D_08_NGS_34_H08.fsa
MLID_D_25_NGS_38_A11.fsa
MLID_D_36_NGS_41_D12.fsa
MLID_D_37_NGS_42_E12.fsa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}