// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_([^_]+_[^_]+)_[^_]+\.\w+$").unwrap();
let string = "MLID_D_08_NGS_34_H08.fsa
MLID_D_25_NGS_38_A11.fsa
MLID_D_36_NGS_41_D12.fsa
MLID_D_37_NGS_42_E12.fsa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}