import re
regex = re.compile(r"_([^_]+_[^_]+)_[^_]+\.\w+$", flags=re.MULTILINE)
test_str = ("MLID_D_08_NGS_34_H08.fsa\n"
"MLID_D_25_NGS_38_A11.fsa\n"
"MLID_D_36_NGS_41_D12.fsa\n"
"MLID_D_37_NGS_42_E12.fsa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")