$re = '/_([^_]+_[^_]+)_[^_]+\.\w+$/m';
$str = 'MLID_D_08_NGS_34_H08.fsa
MLID_D_25_NGS_38_A11.fsa
MLID_D_36_NGS_41_D12.fsa
MLID_D_37_NGS_42_E12.fsa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);