#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"((?:"")?(?:[^"]*(?:"")?[^"]*?)*?(?:"")?)""
Local $sString = ""String"" & @CRLF & _
""""String"""" & @CRLF & _
""String" var "String"" & @CRLF & _
""""String" var" & @CRLF & _
""My ""Amazing"" string"" & @CRLF & _
""String"" & @CRLF & _
""My" var """very""" var "complex" var """" var "string ""with"" vars"" & @CRLF & _
""String"""" & @CRLF & _
""String"" ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")