$re = '/"((?:"")?(?:[^"]*(?:"")?[^"]*?)*?(?:"")?)"/m';
$str = '"String"
"""String"""
"String" var "String"
"""String" var
"My ""Amazing"" string"
"String"
"My" var """very""" var "complex" var """" var "string ""with"" vars"
"String"""
"String"" "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);