using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""((?:"")?(?:[^""]*(?:"")?[^""]*?)*?(?:"")?)""";
string input = @"""String""
""""String""""
""String"" var ""String""
""""String"" var
""My ""Amazing"" string""
""String""
""My"" var """"very"""" var ""complex"" var """" var ""string ""with"" vars""
""String""""
""String"" """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}