package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"((?:"")?(?:[^"]*(?:"")?[^"]*?)*?(?:"")?)"`)
var str = `"String"
"""String"""
"String" var "String"
"""String" var
"My ""Amazing"" string"
"String"
"My" var """very""" var "complex" var """" var "string ""with"" vars"
"String"""
"String"" "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}