using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|^(\d)|\D(\d))(?!\d)";
string input = @"""R3g3x""
""J4v4scr1pt""
1nĂcio""
""Fina1""
""Dup10""
abc10xyz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}