Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?|^(\d)|\D(\d))(?!\d)
/
gm
Test String
New
"R3g3x" "J4v4scr1pt" 1nício" "Fina1" "Dup10" abc10xyz