import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|^(\\d)|\\D(\\d))(?!\\d)";
final String string = "\"R3g3x\"\n"
+ "\"J4v4scr1pt\"\n"
+ "1nĂcio\"\n"
+ "\"Fina1\"\n"
+ "\"Dup10\"\n"
+ "abc10xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}