using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"action\=\""deny\"" scrip\=10\.12\.55\.55 dstip=192\.168\.10\.0";
string input = @"action=""deny"" scrip=10.12.55.55 dstip=192.168.10.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}