$re = '/action\=\"deny\" scrip\=10\.12\.55\.55 dstip=192\.168\.10\.0/m';
$str = 'action="deny" scrip=10.12.55.55 dstip=192.168.10.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);