package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)action\=\"deny\" scrip\=10\.12\.55\.55 dstip=192\.168\.10\.0`)
var str = `action="deny" scrip=10.12.55.55 dstip=192.168.10.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}