re = /action\=\"deny\" scrip\=10\.12\.55\.55 dstip=192\.168\.10\.0/m
str = 'action="deny" scrip=10.12.55.55 dstip=192.168.10.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end