#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-z0-9øåæäöüß]+)*$"
Local $sString = "No-idea,if-is-what,you-want" & @CRLF & _
"No-idea,if-is-whatyou-want" & @CRLF & _
"No-idea,if-is-whatyou-" & @CRLF & _
"No-idea,if-is-whatyou,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")