import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-z0-9øåæäöüß]+)*$";
final String string = "No-idea,if-is-what,you-want\n"
+ "No-idea,if-is-whatyou-want\n"
+ "No-idea,if-is-whatyou-\n"
+ "No-idea,if-is-whatyou,";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}