re = /^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-z0-9øåæäöüß]+)*$/im
str = 'No-idea,if-is-what,you-want
No-idea,if-is-whatyou-want
No-idea,if-is-whatyou-
No-idea,if-is-whatyou,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end