const regex = /^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-z0-9øåæäöüß]+)*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-z0-9øåæäöüß]+)*$', 'gim')
const str = `No-idea,if-is-what,you-want
No-idea,if-is-whatyou-want
No-idea,if-is-whatyou-
No-idea,if-is-whatyou,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}