using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"access-list\s(?P<interface>[^\s]+)\s(extended)\s(?P<allowed>permit|deny)\s(?P<protocol>ip|tcp|udp|any)\s(?P<source>any[46]?)\s(?P<dest>host\s[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\seq\s(?P<services>[^\s]+)?";
string input = @"access-list https_in extended permit tcp any host 209.164.3.5 eq https";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}