$re = '/access-list\s(?P<interface>[^\s]+)\s(extended)\s(?P<allowed>permit|deny)\s(?P<protocol>ip|tcp|udp|any)\s(?P<source>any[46]?)\s(?P<dest>host\s[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\seq\s(?P<services>[^\s]+)?/m';
$str = 'access-list https_in extended permit tcp any host 209.164.3.5 eq https';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);