import Foundation
let pattern = #"access-list\s(?P<interface>[^\s]+)\s(extended)\s(?P<allowed>permit|deny)\s(?P<protocol>ip|tcp|udp|any)\s(?P<source>any[46]?)\s(?P<dest>host\s[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\seq\s(?P<services>[^\s]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"access-list https_in extended permit tcp any host 209.164.3.5 eq https"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)