const regex = /access-list\s(?P<interface>[^\s]+)\s(extended)\s(?P<allowed>permit|deny)\s(?P<protocol>ip|tcp|udp|any)\s(?P<source>any[46]?)\s(?P<dest>host\s[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})\seq\s(?P<services>[^\s]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('access-list\\s(?P<interface>[^\\s]+)\\s(extended)\\s(?P<allowed>permit|deny)\\s(?P<protocol>ip|tcp|udp|any)\\s(?P<source>any[46]?)\\s(?P<dest>host\\s[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})\\seq\\s(?P<services>[^\\s]+)?', 'gm')
const str = `access-list https_in extended permit tcp any host 209.164.3.5 eq https`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}