using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[img](.*)\[\/img]";
string input = @"[url=https://flic.kr/p/H76qHm][img]https://farm1.staticflickr.com/821/26979585158_10b6472384_b.jpg[/img][/url][url=https://flic.kr/p/H76qHm]IMG_6376[/url] by [url=https://www.flickr.com/photos/158618475@N07/]Max[/url], auf Flickr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}