$re = '/\[img](.*)\[\/img]/';
$str = '[url=https://flic.kr/p/H76qHm][img]https://farm1.staticflickr.com/821/26979585158_10b6472384_b.jpg[/img][/url][url=https://flic.kr/p/H76qHm]IMG_6376[/url] by [url=https://www.flickr.com/photos/158618475@N07/]Max[/url], auf Flickr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);