// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[img](.*)\[\/img]").unwrap();
let string = "[url=https://flic.kr/p/H76qHm][img]https://farm1.staticflickr.com/821/26979585158_10b6472384_b.jpg[/img][/url][url=https://flic.kr/p/H76qHm]IMG_6376[/url] by [url=https://www.flickr.com/photos/158618475@N07/]Max[/url], auf Flickr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}