import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[img](.*)\\[\\/img]";
final String string = "[url=https://flic.kr/p/H76qHm][img]https://farm1.staticflickr.com/821/26979585158_10b6472384_b.jpg[/img][/url][url=https://flic.kr/p/H76qHm]IMG_6376[/url] by [url=https://www.flickr.com/photos/158618475@N07/]Max[/url], auf Flickr";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}