#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^,]+)=(.+?)(?:(?=,[^,]+=)|$)"
Local $sString = "arg1 = value1 ,arg2 = value2 ,arg3=uuu," & @CRLF & _
"arg1 = value1 ,arg2 = value2 , arg3=uuu," & @CRLF & _
"arg1 = value,1 ,arg2 = value2 , arg3=u,uuarg1 = ,value,1 ,arg2 = value2 , arg3=u,uu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")