re = /([^,]+)=(.+?)(?:(?=,[^,]+=)|$)/m
str = 'arg1 = value1 ,arg2 = value2 ,arg3=uuu,
arg1 = value1 ,arg2 = value2 , arg3=uuu,
arg1 = value,1 ,arg2 = value2 , arg3=u,uuarg1 = ,value,1 ,arg2 = value2 , arg3=u,uu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end