using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]+)=(.+?)(?:(?=,[^,]+=)|$)";
string input = @"arg1 = value1 ,arg2 = value2 ,arg3=uuu,
arg1 = value1 ,arg2 = value2 , arg3=uuu,
arg1 = value,1 ,arg2 = value2 , arg3=u,uuarg1 = ,value,1 ,arg2 = value2 , arg3=u,uu";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}