using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![aeiou])[a-z]";
string input = @"regex=""[a-z&&[^aeiou]]"";
source=""Only the Lowercase Consonants Should Be Matched."";
Regex_Skeleton.displayHighlightedResults(regex, source);
regex=""(?:(?![aeiou])[a-z])"";
Regex_Skeleton.displayHighlightedResults(regex, source);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}