import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![aeiou])[a-z]";
final String string = "regex=\"[a-z&&[^aeiou]]\";\n"
+ " source=\"Only the Lowercase Consonants Should Be Matched.\";\n"
+ " Regex_Skeleton.displayHighlightedResults(regex, source);\n"
+ " regex=\"(?:(?![aeiou])[a-z])\"; \n"
+ " Regex_Skeleton.displayHighlightedResults(regex, source);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}