re = /(?![aeiou])[a-z]/
str = 'regex="[a-z&&[^aeiou]]";
source="Only the Lowercase Consonants Should Be Matched.";
Regex_Skeleton.displayHighlightedResults(regex, source);
regex="(?:(?![aeiou])[a-z])";
Regex_Skeleton.displayHighlightedResults(regex, source);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end