import re
regex = re.compile(r"(?![aeiou])[a-z]")
test_str = ("regex=\"[a-z&&[^aeiou]]\";\n"
" source=\"Only the Lowercase Consonants Should Be Matched.\";\n"
" Regex_Skeleton.displayHighlightedResults(regex, source);\n"
" regex=\"(?:(?![aeiou])[a-z])\"; \n"
" Regex_Skeleton.displayHighlightedResults(regex, source);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")