#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<span class="place ville">Ville : <span><.+?>(.+?)<\/|<span class="place ville">Ville : <span>([^<]+)?<"
Local $sString = "<span class="place ville">Ville : <span>City name</span></span>" & @CRLF & _
"<span class="place ville">Ville : <span><a href="https://example.com">City name</a></span></span>" & @CRLF & _
"<span class="place ville">Ville : <span>Århus</span></span>" & @CRLF & _
"<span class="place ville">Ville : <span><a href="https://example.com">City name</a></span></span>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")