using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""place ville"">Ville : <span><.+?>(.+?)<\/|<span class=""place ville"">Ville : <span>([^<]+)?<";
string input = @"<span class=""place ville"">Ville : <span>City name</span></span>
<span class=""place ville"">Ville : <span><a href=""https://example.com"">City name</a></span></span>
<span class=""place ville"">Ville : <span>Århus</span></span>
<span class=""place ville"">Ville : <span><a href=""https://example.com"">City name</a></span></span>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}