import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"place ville\">Ville : <span><.+?>(.+?)<\\/|<span class=\"place ville\">Ville : <span>([^<]+)?<";
final String string = "<span class=\"place ville\">Ville : <span>City name</span></span>\n"
+ "<span class=\"place ville\">Ville : <span><a href=\"https://example.com\">City name</a></span></span>\n"
+ "<span class=\"place ville\">Ville : <span>Århus</span></span>\n"
+ "<span class=\"place ville\">Ville : <span><a href=\"https://example.com\">City name</a></span></span>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}