// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span class="place ville">Ville : <span><.+?>(.+?)<\/|<span class="place ville">Ville : <span>([^<]+)?<"#).unwrap();
let string = "<span class=\"place ville\">Ville : <span>City name</span></span>
<span class=\"place ville\">Ville : <span><a href=\"https://example.com\">City name</a></span></span>
<span class=\"place ville\">Ville : <span>Århus</span></span>
<span class=\"place ville\">Ville : <span><a href=\"https://example.com\">City name</a></span></span>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}