using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{\s*([\w]+)\s*\}\}";
string input = @"This is an {{example{}{}}} of a {{string}} that you want to {{parse}}.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}