$re = '/\{\{\s*([\w]+)\s*\}\}/';
$str = 'This is an {{example{}{}}} of a {{string}} that you want to {{parse}}.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);