re = /\{\{\s*([\w]+)\s*\}\}/
str = 'This is an {{example{}{}}} of a {{string}} that you want to {{parse}}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end