package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\{\s*([\w]+)\s*\}\}`)
var str = `This is an {{example{}{}}} of a {{string}} that you want to {{parse}}.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}