package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\+.*`)
var str = `0+171235652++zu
or
122+115166747++en`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}